flutter packages get failed depends on flutter_test any from sdk which requires SDK version

I was having a similar issue:

Running "flutter packages get" in austin-feeds-me-flutter...
The current Dart SDK version is 2.0.0-dev.58.0.flutter-f981f09760.

Because austin_feeds_me depends on palette_generator any which requires SDK version >=2.0.0-dev.61.0 <3.0.0, version solving failed.
pub get failed (1)
Process finished with exit code 1

I fixed it with the following commands:

flutter channel dev
flutter upgrade

Fix source: https://github.com/flutter/flutter/issues/19382

Leave a Comment